import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(?=[^А-Яа-я\\s]{9,})((?=.*[!@#$%^&*()\\-_=+\\{\\};:,<.>]){1})(?=[^А-Яа-я\\s]+\\d|\\d)((?=[^А-Яа-я\\s]+[a-z]|[a-z]){1})((?=[^А-Яа-я\\s]+[A-Z]|[A-Z]){1})[^А-Яа-я\\s]+$)";
final String string = "345DFGdfdgkk$%#\n"
+ "$lkdf4345FD53\n"
+ "34lkjl53$f,4D\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}