re = /(^(?=[^А-Яа-я\s]{9,})((?=.*[!@#$%^&*()\-_=+{};:,<.>]){1})(?=[^А-Яа-я\s]+\d|\d)((?=[^А-Яа-я\s]+[a-z]|[a-z]){1})((?=[^А-Яа-я\s]+[A-Z]|[A-Z]){1})[^А-Яа-я\s]+$)/m
str = '345DFGdfdgkk$%#
$lkdf4345FD53
34lkjl53$f,4D
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end