const regex = /(^(?=[^А-Яа-я\s]{9,})((?=.*[!@#$%^&*()\-_=+{};:,<.>]){1})(?=[^А-Яа-я\s]+\d|\d)((?=[^А-Яа-я\s]+[a-z]|[a-z]){1})((?=[^А-Яа-я\s]+[A-Z]|[A-Z]){1})[^А-Яа-я\s]+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^(?=[^А-Яа-я\\s]{9,})((?=.*[!@#$%^&*()\\-_=+{};:,<.>]){1})(?=[^А-Яа-я\\s]+\\d|\\d)((?=[^А-Яа-я\\s]+[a-z]|[a-z]){1})((?=[^А-Яа-я\\s]+[A-Z]|[A-Z]){1})[^А-Яа-я\\s]+$)', 'gm')
const str = `345DFGdfdgkk\$%#
\$lkdf4345FD53
34lkjl53\$f,4D
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}