using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+:-\s*";
string input = @"0:- Profile 1
1:- Archetype Realist*in
2:- RIASEC Code: R- Realistic
3:- Subline Deine Stärke? Du bleibst dir selber treu.
4:- Copy Dein Erfolg basiert auf deiner praktischen Ver...";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}