import re
regex = re.compile(r"^\d+:-\s*", flags=re.MULTILINE)
test_str = ("0:- Profile 1\n"
"1:- Archetype Realist*in\n"
"2:- RIASEC Code: R- Realistic\n"
"3:- Subline Deine Stärke? Du bleibst dir selber treu.\n"
"4:- Copy Dein Erfolg basiert auf deiner praktischen Ver...")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")