$re = '/^\d+:-\s*/m';
$str = '0:- Profile 1
1:- Archetype Realist*in
2:- RIASEC Code: R- Realistic
3:- Subline Deine Stärke? Du bleibst dir selber treu.
4:- Copy Dein Erfolg basiert auf deiner praktischen Ver...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);