const regex = /aaa|bbb|ccc/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('aaa|bbb|ccc', 'ig')
const str = `AAA
aaa
BBB
bbb
CCC
ccc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}