$re = '/aaa|bbb|ccc/i';
$str = 'AAA
aaa
BBB
bbb
CCC
ccc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);