using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[^/])\/(?=[^\/])([\w\s\S]*)$";
string input = @"https://documentosavanzopr.s3.amazonaws.com/1090525908/3/Requests/13645/paymentSupport-a3a27d291f20b743.pdf";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}