import re
regex = re.compile(r"(?<=[^/])\/(?=[^\/])([\w\s\S]*)$")
test_str = "https://documentosavanzopr.s3.amazonaws.com/1090525908/3/Requests/13645/paymentSupport-a3a27d291f20b743.pdf"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")