$re = '/(?P<name>\w+):[a-zA-Z<>]*\[?(?P<shape>(?:(?:\w*)\s*,?)*)\]/m';
$str = 'a: [1, 2, 3]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);