re = /(?P<name>\w+):[a-zA-Z<>]*\[?(?P<shape>(?:(?:\w*)\s*,?)*)\]/m
str = 'a: [1, 2, 3]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end