package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Date collected: (\d\d\/\d\d\/\d\d\d\d)`)
var str = `Date collected: Date collected: 01/08/2019`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}