re = /Date collected: (\d\d\/\d\d\/\d\d\d\d)/m
str = 'Date collected: Date collected: 01/08/2019'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end