using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^\/]+?)(?:[\/-](\d+))?$";
string input = @"ThePixies1996
7ThePixies
The-Pixies
The-Pixies-1234567
The-Pixies/1234567";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}