$re = '/^([^\/]+?)(?:[\/-](\d+))?$/m';
$str = 'ThePixies1996
7ThePixies
The-Pixies
The-Pixies-1234567
The-Pixies/1234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);