package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^\/]+?)(?:[\/-](\d+))?$`)
var str = `ThePixies1996
7ThePixies
The-Pixies
The-Pixies-1234567
The-Pixies/1234567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}