#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:DE(?:\s*\d){20}|AT(?:\s*\d){18})\b(?!\s*\d)"
Local $sString = "################## Germany IBAN ##################" & @CRLF & _
"DE59290501010001149590" & @CRLF & _
"DE62500105179628448387" & @CRLF & _
"DE55500105172374652131" & @CRLF & _
"DE50500105176152274153" & @CRLF & _
"" & @CRLF & _
"DE 0712 3412 3412 3412 3412" & @CRLF & _
"DE07 1234 1234 1234 1234 12" & @CRLF & _
"DE07 1234 1234 1234 123412" & @CRLF & _
"" & @CRLF & _
"Mashine friendly DE07123412341234123412 style" & @CRLF & _
"This format DE07 1234 1234 1234 1234 12 is given by DIN" & @CRLF & _
"Human DE07 1234 1234 1234 123412 readable" & @CRLF & _
"Not good DE07 12341234 1234123412 readable" & @CRLF & _
"" & @CRLF & _
"################## Austrian IBAN ##################" & @CRLF & _
"AT59290501010001149590" & @CRLF & _
"AT62500105179628448387" & @CRLF & _
"AT55500105172374652131" & @CRLF & _
"AT50500105176152274153" & @CRLF & _
"" & @CRLF & _
"AT 0712 3412 3412 3412 3412" & @CRLF & _
"AT07 1234 1234 1234 1234 12" & @CRLF & _
"AT07 1234 1234 1234 123412" & @CRLF & _
"" & @CRLF & _
"Mashine friendly AT07123412341234123412 style" & @CRLF & _
"This format AT07 1234 1234 1234 1234 12 is given by DIN" & @CRLF & _
"Human AT07 1234 1234 1234 123412 readable" & @CRLF & _
"Not good AT07 12341234 1234123412 readable" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")