import Foundation
let pattern = #"\b(?:DE(?:\s*\d){20}|AT(?:\s*\d){18})\b(?!\s*\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ###################"""
################## Germany IBAN ##################
DE59290501010001149590
DE62500105179628448387
DE55500105172374652131
DE50500105176152274153
DE 0712 3412 3412 3412 3412
DE07 1234 1234 1234 1234 12
DE07 1234 1234 1234 123412
Mashine friendly DE07123412341234123412 style
This format DE07 1234 1234 1234 1234 12 is given by DIN
Human DE07 1234 1234 1234 123412 readable
Not good DE07 12341234 1234123412 readable
################## Austrian IBAN ##################
AT59290501010001149590
AT62500105179628448387
AT55500105172374652131
AT50500105176152274153
AT 0712 3412 3412 3412 3412
AT07 1234 1234 1234 1234 12
AT07 1234 1234 1234 123412
Mashine friendly AT07123412341234123412 style
This format AT07 1234 1234 1234 1234 12 is given by DIN
Human AT07 1234 1234 1234 123412 readable
Not good AT07 12341234 1234123412 readable
"""###################
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)