$re = '/(?<!:):(?!:)/';
$str = '/path/to/file/namespace/filename:line_number:error message Namespace\\ClassName::method().';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;