import Foundation
let pattern = #"(?<!:):(?!:)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"/path/to/file/namespace/filename:line_number:error message Namespace\ClassName::method()."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)