package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^http[s]?:\/\/\w+(\.\w+)*(:[0-9]+)?\/?(\/[.\S]*)*$`)
var str = `https://localhost:8080/param/etp_fai?kaik=09&`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}