const regex = new RegExp('^http[s]?:\\/\\/\\w+(\\.\\w+)*(:[0-9]+)?\\/?(\\/[.\\S]*)*$', 'gm')
const str = `https://localhost:8080/param/etp_fai?kaik=09&`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}