re = /^http[s]?:\/\/\w+(\.\w+)*(:[0-9]+)?\/?(\/[.\S]*)*$/m
str = 'https://localhost:8080/param/etp_fai?kaik=09&'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end