#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+(?:\.\d+){3}\|(?!(?:[1-9]\d{0,3}|[1-5]\d{4}|6[0-4]\d{3}|65[0-4]\d{2}|655[0-2]\d|6553[0-5])$)(.*)$"
Local $sString = "8.8.8.8|0" & @CRLF & _
" (bad: port 0 not allowed)" & @CRLF & _
"8.8.8.8|1" & @CRLF & _
" (good)" & @CRLF & _
"8.8.8.8|65536" & @CRLF & _
"8.8.8.8|6553" & @CRLF & _
" (bad: port > 65535)" & @CRLF & _
"8.8.8.8|dawda" & @CRLF & _
" (bad: char)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")