import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+(?:\\.\\d+){3}\\|(?!(?:[1-9]\\d{0,3}|[1-5]\\d{4}|6[0-4]\\d{3}|65[0-4]\\d{2}|655[0-2]\\d|6553[0-5])$)(.*)$";
final String string = "8.8.8.8|0\n"
+ " (bad: port 0 not allowed)\n"
+ "8.8.8.8|1\n"
+ " (good)\n"
+ "8.8.8.8|65536\n"
+ "8.8.8.8|6553\n"
+ " (bad: port > 65535)\n"
+ "8.8.8.8|dawda\n"
+ " (bad: char)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}