re = /^\d+(?:\.\d+){3}\|(?!(?:[1-9]\d{0,3}|[1-5]\d{4}|6[0-4]\d{3}|65[0-4]\d{2}|655[0-2]\d|6553[0-5])$)(.*)$/m
str = '8.8.8.8|0
(bad: port 0 not allowed)
8.8.8.8|1
(good)
8.8.8.8|65536
8.8.8.8|6553
(bad: port > 65535)
8.8.8.8|dawda
(bad: char)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end