re = /^[A-Z]\d\d[.]?\d?\d?$/m
str = 'D99
M00.0
M01.6
J98.3
T05.0
D96.81
M68.20
9D.0
6G
7H.
M96.811
J234.82
G687.1
GU87.11
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end