// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Z]\d\d[.]?\d?\d?$").unwrap();
let string = "D99
M00.0
M01.6
J98.3
T05.0
D96.81
M68.20
9D.0
6G
7H.
M96.811
J234.82
G687.1
GU87.11
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}