package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+?) & (.+?) & (.*)`)
var str = `Dreamy & Claire Willis & Daniel Kandi
Earth & Wind & Fire
Jimmy & James & The Tempos
Don't work for
Bob & Graeme & Sean & Greg
Legrand & Charrie & Aulivier & Danot
Jimmy Page & Robert Plant`
var substitution = "$1 & $3 & $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}