import Foundation
let pattern = #"(.+?) & (.+?) & (.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Dreamy & Claire Willis & Daniel Kandi
Earth & Wind & Fire
Jimmy & James & The Tempos
Don't work for
Bob & Graeme & Sean & Greg
Legrand & Charrie & Aulivier & Danot
Jimmy Page & Robert Plant
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 & $3 & $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)