using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bEMail=""\K[^\s""@]+@[^\s""@]+(?="")";
string input = @"<myNode EMail=""foo@bar.de"">
<myNode EMail=""alpha@beta.com"">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}