re = /\bEMail="\K[^\s"@]+@[^\s"@]+(?=")/m
str = '<myNode EMail="foo@bar.de">
<myNode EMail="alpha@beta.com">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end