$re = '/\bEMail="\K[^\s"@]+@[^\s"@]+(?=")/m';
$str = '<myNode EMail="foo@bar.de">
<myNode EMail="alpha@beta.com">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);