const regex = /(.)\1{4,}/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.)\\1{4,}', 'gmi')
const str = `aqwerv345g3465vg324
3333333333
34ccccccccc
34tg3qw4qqQqqq`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}