re = /(.)\1{4,}/mi
str = 'aqwerv345g3465vg324
3333333333
34ccccccccc
34tg3qw4qqQqqq'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end