$re = '/(.)\1{4,}/mi';
$str = 'aqwerv345g3465vg324
3333333333
34ccccccccc
34tg3qw4qqQqqq';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);