package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\|]*\|[^\|]*\|([^1])`)
var str = `abc123||1|consent|trigger||||||
abc123||0|consent|trigger||||||
abc123|||consent|trigger||||||`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}