re = /^[^\|]*\|[^\|]*\|([^1])/m
str = 'abc123||1|consent|trigger||||||
abc123||0|consent|trigger||||||
abc123|||consent|trigger||||||'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end