$re = '/^[^\|]*\|[^\|]*\|([^1])/m';
$str = 'abc123||1|consent|trigger||||||
abc123||0|consent|trigger||||||
abc123|||consent|trigger||||||';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);