$re = '/\'(?!(?<=[A-Za-z]\')[A-Za-z])/m';
$str = '\'I don\'t go to work tomorrow 2\'5\'';
$subst = "\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;