import re
regex = re.compile(r"'(?!(?<=[A-Za-z]')[A-Za-z])", flags=re.MULTILINE)
test_str = "'I don't go to work tomorrow 2'5'"
subst = "\""
result = regex.sub(subst, test_str)
if result:
print(result)