re = /^\d+\s*([+-]\s*\d+\s*)*=\s*\d+$/m
str = '2 2 + 2
2 +2=4
3 - 2=1
2 4-2=6
2 + 2 + 4 +6 -3=2
2=2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end