package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Error.*found`)
var str = `Notify: Transaction "Transaction 2" started. [MsgId: MMSG-16999]
t=00027899ms: Step Coded line #17: Click on About Us link started [MsgId: MMSG-205180] [MsgId: MMSG-205180]
t=00054300ms: Error -205177: Step Coded line #17: Click on About Us link failed - Target object was not found. Identification Method: Descriptors Snapshot Info [MSH 1 0] [MsgId: MERR-205177] [MsgId: MERR-205177]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}