import Foundation
let pattern = #"Error.*found"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
Notify: Transaction "Transaction 2" started. [MsgId: MMSG-16999]
t=00027899ms: Step Coded line #17: Click on About Us link started [MsgId: MMSG-205180] [MsgId: MMSG-205180]
t=00054300ms: Error -205177: Step Coded line #17: Click on About Us link failed - Target object was not found. Identification Method: Descriptors Snapshot Info [MSH 1 0] [MsgId: MERR-205177] [MsgId: MERR-205177]
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)