const regex = /Error.*found/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Error.*found', 'g')
const str = `Notify: Transaction "Transaction 2" started. [MsgId: MMSG-16999]
t=00027899ms: Step Coded line #17: Click on About Us link started [MsgId: MMSG-205180] [MsgId: MMSG-205180]
t=00054300ms: Error -205177: Step Coded line #17: Click on About Us link failed - Target object was not found. Identification Method: Descriptors Snapshot Info [MSH 1 0] [MsgId: MERR-205177] [MsgId: MERR-205177]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}