import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|\\s)[A-Za-z0-9][A-Za-z0-9._-]*@[A-Za-z0-9]+(\\s|$)|(^|\\s)[A-Za-z0-9][A-Za-z0-9._-]*@[A-Za-z0-9]+\\.[A-Za-z]+(\\s|$)|(^|\\s)[A-Za-z0-9][A-Za-z0-9._-]*@[A-Za-z0-9]+\\.[A-Za-z]+\\.[A-Za-z]+(\\s|$)";
final String string = " is exactly it! Only a dot can appear after an email (not before). And the email 'username' cant be finished with non-alphanumerical characters (so .stack_@gmail.com is invalid and so is stack.@gmail.com or stack@_gmail.com). The other relevant thing is that emails can have zero or more domains, so: stack@gmail or stack@gmail.com or stack@gmail.com.br are all valid";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}