# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^|\s)[A-Za-z0-9][A-Za-z0-9._-]*@[A-Za-z0-9]+(\s|$)|(^|\s)[A-Za-z0-9][A-Za-z0-9._-]*@[A-Za-z0-9]+\.[A-Za-z]+(\s|$)|(^|\s)[A-Za-z0-9][A-Za-z0-9._-]*@[A-Za-z0-9]+\.[A-Za-z]+\.[A-Za-z]+(\s|$)"
test_str = " is exactly it! Only a dot can appear after an email (not before). And the email 'username' cant be finished with non-alphanumerical characters (so .stack_@gmail.com is invalid and so is stack.@gmail.com or stack@_gmail.com). The other relevant thing is that emails can have zero or more domains, so: stack@gmail or stack@gmail.com or stack@gmail.com.br are all valid"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.