$re = '/(^|\s)[A-Za-z0-9][A-Za-z0-9._-]*@[A-Za-z0-9]+(\s|$)|(^|\s)[A-Za-z0-9][A-Za-z0-9._-]*@[A-Za-z0-9]+\.[A-Za-z]+(\s|$)|(^|\s)[A-Za-z0-9][A-Za-z0-9._-]*@[A-Za-z0-9]+\.[A-Za-z]+\.[A-Za-z]+(\s|$)/m';
$str = ' is exactly it! Only a dot can appear after an email (not before). And the email \'username\' cant be finished with non-alphanumerical characters (so .stack_@gmail.com is invalid and so is stack.@gmail.com or stack@_gmail.com). The other relevant thing is that emails can have zero or more domains, so: stack@gmail or stack@gmail.com or stack@gmail.com.br are all valid';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);