using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\d\s*){5}\d";
string input = @"1 23456
1 2 3456
1 2 3 456
1 2 3 4 56
1 2 3 4 5 6";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}